DIGITAL MEDIA WORKSHOP-Flash Animation
Getting Started
Depending on the version of Flash you are using, panels will be in different places. It takes a little getting used to, but you should be able to adapt to any of those versions if you know the basics. You can always check out the variations of screen setups, called Workspaces, under the Window>Workspace menu.
Decisions, Decisions…
Before you create a new Flash file (FLA), you need to consider a few things:
· What size do you want this animation to be?  (can be changed, but objects will not be resized to match if you change your mind later) 
· What color do you want the background to be?  (can be changed, but it stays the same for the entire project for all scenes)
· What frame rate do you want to use? (can be changed at any time) Higher number of frames per second (fps) means what is on your timeline will play faster.
Your  Turn—Part 1
1. Create a new Flash file with Actionscript 3, blue background/stage color, 12 frames per second, and a Stage size of 800px wide by 600px tall. Save as CARD.FLA.
Basic Drawing
[image: ]Drawing in Flash is much easier than drawing in some other programs. For one, you don’t have to be an artist to get a decent looking drawing because you can utilize tools to bend and shape existing shapes into new ones. And, you can easily combine shapes into one nice, neat shape.
Some strange things about drawing and shapes in Flash:
· Fills (inside color) and Strokes (borders) of shapes are separate pieces. It’s a little hard to get used to. Just know that if you decide to pick up a shape and move it around, you have to double click it to select both parts.
· Overlapped shapes eat each other. Well, sorta. If you put a shape over a shape and then move the top shape, the part that was previously hidden will disappear.
· Touching shapes become one shape if there is no stroke or the stroke dividing the shapes is removed. They will then move as one or can be filled in with the Paint Bucket.
· [image: ]The Paint Bucket changes the fill color; the Pencil changes the stroke color. 
[image: ]Your Turn—Part 2
2. Select the Oval tool (can press O, it hides under the Rectangle tool).
3. Select yellow as the Fill color and black as the Stroke (border) color. Click and drag to draw these two ovals as shown. Be sure to draw the big one first so the small one is on top. 


4. 
 
5. [image: ] It is a good idea to keep drawings and their pieces separate (so you can animate them and such later on). So, unlike we have done at this point, which is just “draw stuff” on the Stage, you typically want to make drawings inside a safe, place. These safe places are called Symbols in Flash. So, let’s take our current drawing and convert it to a symbol so we can keep working on it. Select All (Control+A or you can take the black arrow tool and just draw a box around everything) and then click Modify>Convert to Symbol (or press F8).  Name the Symbol bee and set the type to Movie Clip. Then, press OK.
 
6. [image: ] Notice that you now have a blue bounding box around your bee. You can’t edit the bee while the bounding box is around it. To edit, we have to get INSIDE the symbol. A symbol has its own Timeline and its own Layers. Double click the symbol OR you can locate the symbol in the Library (F11) and bring it up from there. When you double click, you should see the following at the top of your screen indicating you are editing the bee--  
7. Double  click the word Layer 1 and rename that layer beebody. Then, lock the layer so we can’t mess it up by pressing the dot under the padlock: 

8. [image: ][image: ]Next, press the New Layer button below the bee’s Timeline to add a few more layers. Name them as follows and order them as you see here (just click and drag to reorder): 
[image: ]  
9. Lock all layers except legs. We are going to draw the legs using the Pencil (Y) tool. Click on the legs layer, select the Pencil tool, and then look for the Options button

Click and hold
and set to Smooth

 If you draw the legs now, they will get all ugly and pointy (try it if you don’t believe me…you can undo). So, set the Options for the Pencil to Smooth.
 
10. [image: http://www.vinsdojo.com/flashcolor/dont_close_gaps.gif][image: ]Zoom up close (200% or so) and draw in legs. Be sure the “feet” paths are closed or you will have problems filling them in later. Then, fill in with the Paint Bucket.
[image: ]
NOTE: If you cannot fill in the foot, you might have a little gap. Just zoom in super close, take your black arrow tool, and point to the end of the line where the problem is and drag it. Or, look for the option to close gaps and try a different setting—by default, it does not close gaps:

11. Once that’s all done, lock the legs layer. Unlock and select the leftwing layer. 
12. Now we’ll use the Pen[image: ] tool to draw. This tool is pretty neat because you just click (think “dot to dots”) where the corners will be (Do not click and drag! Click, let go, click, let go, etc.). Be sure to close off the path (you may have to guess or you can turn the body of the bee off before you do this part).

13. In the illustration, notice how the line has a curve. Well, to make it curve, AFTER you draw in the wing, just point to that segment. Your mouse will have a little curvy line. Just click and drag that curvy line. Continue to modify the shape to your liking. Fill in the wing with color (doesn’t matter what color for now.)

[image: ]  [image: ]
14. Then, lock this layer, unlock the other wing, and draw it using the same process. Turn the visibility off on the beebody layer if needed.
15. [image: ]Now, lock all layers except the face layer. Using shapes of your choice (I used two circles, a circular paintbrush, and a line that I curved with the black arrow tool), draw a face.
16. [image: ]Finally, let’s “dress up” the body by adding some stripes. Lock all layers except beebody. Then, use the Line tool and draw in sets of lines, fill with black (be sure you have no gaps, so zoom up!), and then use the black arrow tool to point at segments to curve them: (and, if you want, add a stinger)
[image: ]     [image: ]
17. Lastly, add anything else you want to any of the layers (how about some antenna on the face layer?). Science people might want to add a couple more legs.  
[image: ][image: ] Finally, SAVE!!

Gradients
Gradients are a little confusing in Flash because it’s just hard to find. There is not a button for it. To add a gradient as a fill, you just use the Paint Bucket, like all other fills. The exception is that you use the Color Mixer to do it and you change the normal setting (SOLID) to a gradient type (linear, radial, etc.).
Gradient have multiple colors that blend into each other. Those colors are referred to as “stops” and can be added, deleted, or modified at the bottom of the Color panel.
Your Turn—Part 3
18. Remember that we are still working inside the “bee” symbol. At this point, we are going to change the wings to a gradient. Usually, bee wings are somewhat transparent. So, we’ll use a white to blue gradient to mimic the color of wing vs. sky. Lock all layers except the right and left wings.
19. Click the Paint Bucket tool and then bring up the Color panel (Window>Color). 
20. [image: ]Change the settings as follows—radial gradient, light blue to white, with alpha of 70% for each stop:
    [image: ]

Notice Alpha or A is set to 70%, which sets it to have a little bit of transparency. 
21. If you feel so bold, try out a gradient (yellow to orange or something) for the bee’s body. Just remember that the body would not be transparent, so the stops would need to be put back to Alpha of 100%.
[image: ] 
22. Now, exit Symbol editing (we’re done with the bee…for now) by clicking the back arrow to return to Scene 1. [image: ]
23. Save!
 Understanding Symbols
[image: ]You might recall, way back when we started drawing our bee, that we created him as a movie clip Symbol. There are essentially three “symbol types” in Flash—graphic, movie clip, and button. Honestly, I don’t use graphic very often; movie clip does the same thing anyway and more. And, if you decide later on to animate a symbol, it has to be a movie clip anyway. Button is used to create…buttons. 
Symbols have what are called Registration Points. They don’t do a whole lot, but if you start to transform, add action, or rotate a symbol, you’ll learn exactly what that registration point does. When you are editing a symbol, the registration point appears as a crosshair.

If your registration point, like this one, is not in the center, you can go back into Symbol editing, select everything (Control+A) and then position your object with the point in the center.
If you are “transforming” a symbol (Free Transform Tool, Q) you will see a white dot, called a transformation point. It’s easy to accidentally move that around, but again, you typically want to keep that in the center as well. So, just a few minor notes to make in your head. 
[image: ]Your Turn—Part 4
24. Now, the bee is huge, so we will use the Free Transform handles (press Q or choose the tool [image: ] or [image: ]). You will see transformation handles appear around the bee.
 Now, hold Shift (so you can’t mess up the aspect ratio) and resize it down using a corner handle. Note that white circle in the middle—that’s the transformation point.
25. Switch back to the black arrow tool (Selection tool, or press V) and position the bee in the top right corner.
[image: ]     [image: ]
26. [image: ]Now, name that layer (Layer 1) and call it bee.
27. To see what this Flash movie looks like so far, you can test it. Just click Control>Test Scene. It will appear in its own little window. Not much happening so far, huh? Exit the preview.
28. Now, just for fun and to illustrate the concept of Symbols, drag more copies of the bee out of the Library (F11). Using the Transform tool (Q) resize and rotate  them as you please. [image: ]
Why Symbols Rock
So, you see now that Symbols are reusable content. And, because they are stored in the Library and reusable, they really don’t increase file size much. So, that’s a good thing. But, the coolest thing is that Symbols can be edited in one place and all instances of that Symbol are updated automatically. So, if I was having a “bad drawing day” I seriously could just make a symbol and call it man and then just draw a stick man until I feel like taking time to draw a real dude. Neato!
Likewise, if you decide to add animation inside a movie clip Symbol, it will apply to all instances. Let’s do it!
Your Turn—Part 5
29. [image: ]So, let’s update this bee! One thing he’s missing (poor thing) is a nose. So, double click on any bee (pick a bee, any bee) and you will go into Symbol editing mode. Notice everything else “grays out” a bit and you can see all the “bee layers” on the Timeline, so it’s proof you are inside the bee symbol. 
30. [image: ]Zoom up on the bee’s face (Control and +) and unlock only the face layer. 
Draw (with any tool—I used a pencil) in a nose-like feature. Then, return to the Scene,
31. Zoom out (Control and -) so you can see all the bees. Now, they all have little noses! 



 Frame-by-Frame Animation and Keyframes
To do the “fun” stuff in Flash, you have to understand how to animate. And, to animate, you must understand keyframes.
 First is the blank keyframe.
[image: Adobe Flash Blank Keyframe]A blank keyframe has a hollow dot. It represents a frame on the Timeline that is “ready” to hold something. You cannot put objects in frames if they are not blank. If you click on frame 50 and it’s not a blank keyframe and you draw something, it will actually show up not in frame 50, but in the first blank keyframe on that layer. And, if that layer has no blank keyframes, it won’t draw period. When you create a new layer, it automatically has one blank keyframe in frame 1. Pressing F6 in an empty frame creates one of these.
Next is the keyframe.
[image: Adobe Flash Filled Keyframe][image: ]A keyframe has a solid dot. It represents a frame that has something in it. Blank keyframes turn into these when you put something in them. Pressing F6 creates one of these if preceded by a frame with content.
Finally, is the frame span. 
[image: Adobe Flash Frame Span] A frame span represents an area where you are basically telling Flash to just “keep that keyframe” going for awhile. If we wanted our bees to stay on the screen for a certain amount of time, we’d insert a frame span (Insert>Frame). Pressing F5 inserts a frame to continue the frame span.

You can do animation either on the main Timeline or inside symbols. And, whether you do it one way or the other entirely depends on the end goal of your animation. 
Your Turn—Part 6
32. We are going to animate the bee’s wings. So, pick a bee or double click the bee in the Library to start editing on the bee’s timeline. I like to use the Library copy because it will open bigger.
33.  Take a look. Right now, we have five layers with five keyframes holding various parts of the bee’s body. Be sure all layers are locked except for the leftwing layer. Then, click that layer to select the wing. Press Q or click the Free Transform button.
[image: ] 
34. Now, at frame 5 on the leftwing layer, press F6 to insert a keyframe. Why? Well, we want to move the wing at this point so that it appears to flap. Notice when we do this that the rest of the bee disappears. That’s because we did not tell those layers to “stay put.”
[image: ]  See, the legs layer just has empty frames going on… so we see no legs.
35. To fix that, we need to just insert a regular “stay put” frame on all other layers. So, first click on frame 5 of the legs layer and press F5 (frame). There are those silly little legs!
[image: ] [image: ]  Repeat this process for the other layers.
36. Now, we are going to wiggle that leftwing a little bit to make it appear to move. Rotate it a little bit and maybe “smash” it a little bit, too. Just use the transform handles and “make it your own.” Drag the playhead to preview your movement.
37. Next, unlock rightwing (and lock leftwing). In frame 5, press F6 to insert a keyframe so we can make a change. Then, transform the right wing to your liking. 
38. Lock everything back and return to Scene 1, out of symbol editing mode. You will see all those bees hanging out again. However, they aren’t flapping their wings, are they? How dare them!
39. That’s because Movie Clips do not play on the Timeline. The only way to see them is to test the animation. So, click Control>Test Movie and take a look.
40. Pretty nifty, huh? It’s a little troubling since they all match exactly (attack of the clones) but that’s how Symbols work. You could go a step further and make them all blink their eyes or wiggle legs, etc.  But, you get the idea. 
41. Now, just for grins, take your bottom left bee and flip him so he faces the other way (drag your transform handles beyond the boundary or click Modify>Transform>Flip Horizontal).

Tweening
One of the most powerful features of Flash is the ability to “tween” an object. This simply means that you decide where something starts—location and transformation (point A) and where and how it ends (point B) using two keyframes and the built in tweening. There are two kinds of tweening—motion and shape tweens. Motion tweens can only be used on symbols. Shape tweens can only be used on shapes or “broken apart” objects. 
One big thing to note-- Tween only one object per layer. Remember that Flash considers the stroke and the fill to be separate objects. If your path has both, move the stroke and the fill to different layers, and tween them separately but simultaneously. Otherwise, crazy things happen. Trust me. 
Your Turn—Part 7
42. Remember that bee facing the opposite direction? Well, we are going to move him to his own layer so he can be tweened. We want him to fly across the screen. So, simply right click him and CUT.
43. Then, create a new layer, name it bee2, and right click on the Stage and select PASTE IN PLACE. This paste option will put him right back where we cut him from. As it is good practice, let’s lock the bee layer.
44. To make him zoom across the scene, we have to decide the frame span for the movement. As we are using 12 fps for the speed, it will take him one second to cross 12 frames. So, 60 frames would be (60 divided by 12) five seconds. Insert a keyframe (F6) in frame 60.
45. Then, click in frame 60 and move him off the stage to the right.
[image: ] 
46. If you test the scene right now, it’s all kind of crazy. The other bees disappear, he sits there forever, and then it blinks. We must fix this!
47. First, remember, to make his bee friends “stay up there” we need a frame on there. So, press F5 by frame 60 of the bee layer. Now he’s not lonely anymore.
48. Finally, let’s get him moving gradually by inserting a tween. You have two options—Create Motion Tween and Create Classic Tween. Choose the Classic option.
49. So, to insert a tween, just click anywhere between the two keyframes on the bee2 layer. Frame 20, for example. It doesn’t matter. Then, right click and create the appropriate tween. You now should see a long arrow line in a shaded purplish area. That means a tween is happening. Control>Test Scene now and watch the magic as the bee flies across the Stage
50. Next, we will create another tween using the Motion Tween Option. Create a new layer, double click the title of your newly created layer to rename the layer bee3. 
51. Drag a bee out of the library onto bee3, resize and position to your liking. 
[image: ]
52. At this point, you will insert a “new” Motion Tween. This will allow you to refine the animation specifically to your liking. Pick any frame (frame 2 is good) on the bee3 layer, right click, and select Create Motion Tween. The line will turn blue. 
[image: ]

53. Now, select the last frame on the bee3 layer (Frame 60) and add a key frame (F6). This will ‘tell’ the Motion Tween the ending point of the tween. [image: ]




54. [image: ]While still on Frame 60 of the bee3 layer, move your bee to the opposite corner of the stage. This will create a motion path. 
[bookmark: _GoBack]





Bring on the Clipart
Tired of drawing everything? You can actually import clipart images (referred to by Flash as bitmap images) or really just about any other image for use. However, you cannot edit them or do much to them because they are not symbols. 
Clipart is useful for some Flash designers because there is a special option called Trace Bitmap that allows you to take a bitmap image and convert it to shapes and lines. When this happens, you can then recolor the object or make changes to it. 
[image: ]Your Turn—Part 9
55. In your data files is a file called beehive. To bring this image into Flash, click File>Import>Import to Library and browse for the file. It should now be housed in the Library (F11).
56. I’ve found lineart is easiest to work with in Flash. For this beehive, let’s use the Trace Bitmap feature, remove the white background, and make the hive an appropriate color. So, first, make a new layer, name it beehive, and drag it out. It’s rather large.
57. Now, click Modify>Bitmap>Trace Bitmap. This “traces” the bitmap and turns it into a series of “painted” colors (a vector, actually). You can play around with the settings, but the defaults will work with this simple image quite well. 
58. Click on the white background and press delete. Then, use the Paint Bucket and fill in the white spots with an appropriate hive color.
59. Finally, lock all layers except the beehive layer. Then, select the hive (Control+A) and convert it to a movie clip symbol called hive (F8).
60. Reposition the beehive layer to be lower than everything (in the background, essentially). 
[image: ][image: ]
61. And, let’s make the whole thing a little longer before it loops by inserting a frame on all layers in frame 80 (F5).
62. Save!

Shape Tweens
I honestly use shape tweens very little. They tend to do strange things. However, they are a feature of Flash and we should acknowledge that. So, just know this… you can shape tween anything that is “broken apart” (has that gray speckled selection on it when you click on it) and you can break apart anything by pressing Control+B. It doesn’t mean you should, though. Personally, I do not use strokes when I use shape tweens because they go crazy. And, it’s easiest to actually manipulate the starting shape and just change its position, reshape it using the black or white arrows or transform tools, or change its color. Those things will typically work just fine.
Your Turn—Part 10
63. [image: ]Let’s create an animated cloud to put in the background. Create a new layer, call it cloud, and move it to the bottom of the layer stack on the Timeline. Lock all other layers.
64. Now, create a new Symbol—Insert>New Symbol (set to Movie Clip) named cloud. Now, to create it using a Shape tween!
65. Use the Paintbrush set to white and draw a cloud. Then, fill it in with the same color using the Paint Bucket.  
66. With a looping shape tween, it’s a good idea to have the starting and ending frames be the same. So, insert a keyframe at frame 30 (F6) but make no changes.
67. Then, insert a keyframe at frame 15. We’ll make the changes here, in the middle. We want these to be subtle cloud changes, so it won’t be too extreme.
68. While on frame 15, use the Selection arrow (black arrow), click off the cloud, and then point to the curves. Reposition (use the curvy mouse pointer) parts. Not too much. Just a few places.
69. Now, right click on the Timeline between the first two keyframes and Create Shape Tween. Repeat between the last two. You will see shaded green areas on the Timeline. (NOTE: Flash 8/CS3 does not have shape tween on the right click menu and must be selected from the Properties panel under the Tween option—set to Shape)
[image: ]
70. Return to Scene 1. Drag the cloud out of the Library onto the cloud layer you created. Test Scene.

[image: ]There you have it. It’s a Shape Tween. Not the greatest thing since sliced bread, but you might come up with neat uses for it in creating simple animations, such as web banners.
71. Save!



Don’t Change All My Symbols!
Remember that we discussed how updating one symbol updates all of them? Well, what if you don’t want to?
You can “copy” a symbol and disconnect it from the group. To do so, you use the Library. Simply right click a symbol in the Library, Duplicate it, and give it a new name. Then, you will have two identical but unrelated symbols that you can make changes to. When you double click to edit one, it will not affect the other(s).
Your Turn—Part 11
72. In your data files is a file called flower-clipart-01. To bring this image into Flash, click File>Import>Import to Library and browse for the file. It should now be housed in the Library (F11).
73. Create a new movie clip symbol (Insert>New Symbol) and name it orange flower. Drag the flower into this new symbol and use Trace Bitmap (Modify>Bitmap>Trace Bitmap). Remove the background like before and erase the text. Then, return to the scene.
74. [image: ]Create a new layer called flowers. Position near the bottom of the stack, in front of the clouds. Drag two copies of the orange flower symbol to the Stage. Flip one horizontally and scale as you desire.
[image: ]
75. Now, let’s create a different colored flower. To do so, in the Library, right click orangeflower’s movie clip and select Duplicate. Then, give it the name redflower. 
76. [image: ]In the Library, double-click the redflower movie clip and use the Paint Bucket to recolor the flower as you desire.
77. Finally, drag a few copies of the red flower out to the flowers layer. 
NOTE: You can “copy” a flower by holding Alt while dragging!
[image: ] Beautiful! Save!
Sound!
What’s some multimedia without sound, right? You can easily import sound files into Flash to use in projects. There are numerous ways to do it, and we’ll only cover the “easy” way in this session. However, you can add sound many different (and more complicated) ways. Many sound file types are acceptable, though my best luck has been with WAV files. Some MP3 files will not work, so it’s important to test your file (just try to import it) before you get too deep into a project.  Like all other objects, you will import sound to your Library where it will stay until you drag it in to use it.
Your Turn—Part 12
78. Create a new layer called buzz and move it to the top of the stack of layers. Lock all other layers. Then, insert a blank keyframe at frame 40. We want to have a sound play for a little bit and then play again so we need two different “starting” frames.
 [image: ]
79. File>Import>Import to Library and browse for the beebuzz.wav file. It will appear in the Library with a little speaker icon next to it so you can tell it is a sound. [image: ]
80. Next, click on frame 1 and just drag the sound out onto the Stage. When you let go, you should see a waveform representing your sound appear on the Timeline during the duration of the sound. You won’t hear it. NOTE: If you want to hear it, click in the waveform and in the Properties panel, set Sync to Stream.
[image: ]
81. Now click in the blank keyframe on 40 and repeat this process. You will now see two waveforms. Save and Test Scene to check it out. NOTE: If you change your mind about a sound, you can remove it in the Properties panel:
[image: ] [image: ]
82. You can also edit sound in Flash, including adding a Fade in/out or removing “dead air” or trimming a clip. Simply click the pencil under Sound in the Properties panel and making changes to the Edit Envelope dialog box:
[image: ]
Other effects are also available in the Effect drop down menu. Changes only affect that particular sound in those frames, not every instance of the sound in the project.



Scenes
In Flash, you can create multiple scenes for action. As it is, with what we are creating so far, that first scene is pretty full of stuff. It would be distracting to keep going out to frame 100 or 200 or 500 and continue animating. Or, if you wanted to start removing bees, you’d insert many keyframes and start deleting things. It would be very confusing.
So, scenes help with this. To access the Scene panel, where you can add, delete, rename, or reorder scenes, you go to Window>Other Panels>Scene.
Scenes play in the order listed. You can also add special commands (called ActionScript) to make your file NOT go to the next scene so that you can allow users to navigate using buttons. But, one thing at a time!
Your Turn—Part 12
83. [image: ]Open the Scenes panel and rename Scene 1 to be crazybees. It’s the same as renaming a layer—double click it, type it, and press Enter. 
84. Press the little paper icon in the bottom left corner to add a new scene. Name the second scene beehave.
[image: ]   [image: ]
85. We will not reorder these scenes, but you change the order the same way as reordering layers—just click and drag.
86. To change which scene you are working on, look for the clapboard icon and press it. 
Let’s go to the beehave scene next. Select it and Save.



Your Turn—Part 13
87. REVIEW: In this new scene, before we get going on adding text, let’s do a few things you should know how to do based on the previous lessons.
88. Rename Layer 1 in the beehave scene to be background.
89. On this layer, draw the trunk of a tree. Use the Pencil tool to draw it and fill it with brown. I also added a few lines with the pencil tool afterward for effect.
90. [image: ]Next, import the file daisy-clipart-01 to the Library. Then, create a new movie clip symbol (Insert>New Symbol) called daisy, drag the bitmap file into this new symbol, Trace Bitmap (settings will need to be modified a little on this one—try 50 for color threshold, 5 px for minimum area, tight curve fit, and few corners), and remove the background and text. Return to the scene. Drag a few copies of the daisy movie clip out to the background layer. Lock the layer.
[image: ]
91. Now, we’ll have the bee fly in. So, create a new layer named bee. Drag the bee out and position off stage at right. Insert a keyframe (F6) at frame 30 and position the bee in the center of the tree. Insert a Classic Tween (or older versions, Motion Tween) between the frames so he flies into place. (if you can’t guess on position, you can insert a frame—F5—on the background)
92. Create a new layer called swatter. Then, lock all other layers.
93. Create a new movie clip symbol (Insert>New Symbol) called swat. Import the Fly_Swatter.jpg image to the Library, Drag it in. Trace Bitmap and remove the extra stuff and white background. Return to the beehave scene.
94. On the swatter layer, insert a blank keyframe (F6) on frame 30. Drag the swat movie clip onto the stage in this frame. Resize/rotate as shown below.
[image: ] [image: ]
95. Before we go further, be sure your transformation point is at the bottom of the handle. To be sure, just activate Free Transform (Q) and move the white dot to the corner if it’s not already there. It will rotate from this axis.

96. Insert a keyframe (F6) at frame 35 on the swatter layer. Then, in that frame, rotate (Q) the flyswatter up.
[image: ]
97. Insert a Classic Tween between those frames (right click up there on the Timeline).
98. Insert a frame (F5) at frame 125 on all layers. Test Scene. It should “swat” the fly. Make any changes necessary (placement of the bee, for example). Save!
99. Create two more layers for sounds as shown below (lock other layers). On the buzz layer, pull in the beebuzz sound. For the ouch layer, insert a blank keyframe (F6) at 30 and drag in the bonk sound at frame 30 (Import to Library first).
[image: ]
100. Test and Save!
[image: ]
That was a pretty good review! How did you do?
Text
So far, we’ve only use bitmaps or drawn items. But, text is important, too. To insert text, you use the Text Tool  The main thing to remember about text is that if you wish to make changes to it, select it (highlight it) first. Also, don’t try to resize text by resizing the box; use the size slider button to resize the font.
One big change in the newest version is the use of TLF text in Flash files. This will sometimes cause errors, so for beginners, it’s probably best to set text to “Classic Text” and then Static Text as shown below:
[image: ] TLF text is pretty neat. You can use special “classes” with ActionScript to animate this special kind of text. You are also given the really super long character Properties (shown earlier) where you can change lots of things. However, if you are starting out and not utilizing any of those features, Classic/Static Text is all that is necessary to just use and tween basic text. Before we move on, click the text tool and set this as shown above.

Your Turn—Part 14
101. Create a new layer called beehave. Lock remaining layers.
102. Insert a blank keyframe on frame 35. 
103. Use the Text tool and a clear font, size 96, in the gold color from the center of the daisy (use eyedropper). Type the word BEEhave!  Set the text properties to be centered:
[image: ] 
104. Switch to the Selection tool (black arrow) and click the text box. Then, convert the text to a movie clip symbol—F8. Call it text.
105. [image: ]Position the text centered on the stage using the Align panel. Window> Align. Set as follows: [image: ] 
Be sure to check “Align to Stage” before pressing the two buttons!
106. Use the Quick Transform handles (Q) and resize the symbol as shown:
107. We don’t want this text to begin on screen, so let’s move the keyframe. To do that, click on the keyframe 1 and let go. Then, click and don’t let go and drag to frame 30. Then, let go.
[image: ]


108. Now, insert keyframes at 35, 40, and 45 (F6). [image: ]
109. Make the following changes to each of those keyframes:
frame 30—click the text and resize using the handles (Q). Then, in the Properties panel, set Color Effect to Alpha of 0, which is invisible.
[image: ] [image: ]
frame 35—leave as is (big)
frame 40—resize and place in top left corner
[image: ]
frame 45—resize and angel in corner
[image: ]
110. Now, between each of those keyframes, insert Classic Tweens by right clicking between keyframes (old versions, Motion Tween).
111. One little change. Between frames 40 and 45, let’s add a spin. That can be done by clicking in the purple tween area and setting Rotate in the Properties panel to CW (Clockwise) and 1 spin.
[image: ] 



112. Press Enter to preview or Test Scene. Save!
113. Finally, create one more layer called haha. Import the sound behave.wav to the Library. Insert a blank keyframe at frame 40 and drag the sound onto the layer.
[image: ]
114. Save and test one more time!
115. It’s pretty loud. Actually, if you look at the waveform closely, the audio “clips”. So, fix that by lowering the levels. Click in the behave/haha sound and click the pencil (or Edit in previous versions) in the Properties panel to edit the sound. Bring the top lines down as shown to lower the volume: (use the magnifying glasses to zoom out)
[image: ]
If you are satisfied with the volume (press the play button to preview), we’re all done with this scene. 




Flash Buttons
Unlike other symbols that have timelines, buttons have four button states instead. They are:
[image: ]Up The appearance of the button when the pointer is not over it. 
Over The appearance of the button when you place the pointer over it. 
Down The appearance of the button when you click on it. 
Hit Defines the area that will respond to a click of the mouse. 
You can still drag sounds into the various button states and you can drag symbols into the button as well. As a matter of fact, it’s a good idea to create the main part of the button as a symbol first and then add the text on a separate layer within the button. Let’s make that happen.
Your Turn—Part 15
116. Create a new scene called Replay. 
117. Create a new movie clip symbol (Insert>New Symbol) called buttonbox. Inside, draw a shape for the button with a  stroke and fill of your choice. To give the corners a rounded look, set the Rectangle Options in the Properties panel before you draw:
[image: ]   it’s a button in older versions [image: ]
118. After drawing the shape, double click it with the Selection tool to select it. Then, center align it to the Stage (very important for all buttons!) using the Window>Align panel (center horizontally and vertically and set to align to stage).
[image: ]  [image: ]
It will be centered on the registration point.
119. Return to the Scene.
120. Next, create a new symbol (Insert>New Symbol) that is a button type called replaybutton.
[image: ] [image: ]
121. In the UP frame, drag the buttonbox movie clip in. Center it using the Align panel.



122. Press F6 in the OVER frame to copy the symbol to that frame and make it ready for change. We will add a Filter to this frame so that when you are pointing to it, the button glows. To do this, click the Filter drop down in the Properties panel, press the first button and choose Glow, and set the color and blur values. 
[image: ] [image: ]
NOTE: In older versions, this is in a panel beside the Properties panel
[image: ]NOTE: Flash has several filters you can apply to movie clips—blur, glow, bevel, and shadow. You can add more than one filter to a symbol.

123. Now, label that layer box and lock it.
124. [image: ]Create three new layers inside the button—text, sound, and bee. 
125. On the bee layer, insert a keyframe (F6) in the OVER state. Then, bring in two copies of your bee movie clip and size/position as shown, leaving room for the text:
[image: ]
[image: ]
126. On the text layer on the UP state, create the words REPLAY in a font and style of your choice.
[image: ]  [image: ]
127. Import the sound file to the Library called groovy. Insert a blank keyframe (F6) on the sound layer in the OVER state. Then, drag the sound in. 
128. Finally, press F5 to insert a frame on all HIT states.
[image: ]
129. Save and return to the scene.
130. Create two layers—actions and button. Drag the replaybutton to the Stage on the appropriate layer and then lock it. 
[image: ] [image: ]
131. If you save and test, everything should work except 1) Your sound doesn’t play and 2) Your button doesn’t go anywhere.
132. Since this is a button, the Sync for the sound must be set to Event. Clicking a button is considered an “event” in Flash. So, inside the button, click on the waveform and set the Sync to Event in the Properties panel. 
[image: ]
133. Return to the scene.
134. Press Control+Enter to test the entire movie. You will notice that the movie does not stop to give us the opportunity to press the button in the last scene. Also, we haven’t told the button where to go either. That’s up next.





Actions
The power in Flash is the use of ActionScript. It’s a programming language used to tell Flash objects what to do. It can also control the Timeline. 
[image: ]To add Actions, you must use the Actions panel, accessed by pressing F9. Probably the most common action is the stop action:
[image: ]
To attach actions to objects/movie clips/buttons, you must give the item an instance name. This is done in the Properties panel when you are clicked on the object. 
You can tell if ActionScript is in a scene or not by the presence of a little lower case “a” on the timeline:
[image: ]

Your Turn—Part 16
135. We should be at the main Timeline in the replay scene. The button layer should be locked. Click on the actions layer. Open the Actions panel (F9).
[image: ]
136. Now, you must type in the code to control the button. First, we have to “give the button” an ActionScript name. It’s not the same as its Library name. So, we’ll make something up… just call it replay_btn in the code below. Depending on your version of Flash and ActionScript, the code varies.


Flash CS4/CS5 or any version using ActionScript 3.0, here’s the code:
[image: ]

137. Now, it won’t work yet. We have to actually assign that instance name we mentioned (replay_btn) to an object (in this case, our button). So, click on the button (unlock first). In the Properties panel, type in replay_btn as the Instance name in the white box.
[image: ] 
138. Now, if there are no errors (cross your fingers), your project should stop and the button should function. Press Control+Enter to check it out.
139. That’s it! Save and close!

A Few Notes
Every time you Test Scene or Test Movie, you actually create a Flash SWF file, the default “publish” format. These are the types of files that can be embedded onto webpages or PowerPoint files. If you look in your folder, you will see several:
[image: ]You can also specify the export format under File>Publish Settings.






NOTES/ACKNOWLEDGEMENTS/RESOURCES USED
Adobe Flash for Beginners—Graphics & Animation
http://www.bill-morrison.com/class/adobe-flash/1-graphics-animation/index.html
How to draw a cartoon bee
http://www.how-to-draw-funny-cartoons.com/cartoon-bee.html
Beehive
http://www.daniellesplace.com/Images4/beehive72.gif 
Buzzing Sound
http://resources.bravenet.com/audio_clips/sound_effects/animal_-_bee_or_fly_buzz/listen/ 
Fly Swatter 
http://www1.free-clipart.net/gallery2/clipart/Household/Miscellaneous/Fly_Swatter.jpg 
Austin Powers clip “Oh behave”
http://resources.bravenet.com/audio_clips/movies_tv/austin_powers_-_oh_behave_yeah_yeah_baby/listen/ 
Oh Groovy Baby clip
http://www.moviesounds.com/austin.html 
Flower Cliparts
http://www.clipartspace.com/flower-clipart.htm
Bonk Sound
http://www.grsites.com/archive/sounds/view/1618/
Confused Boy
http://www.hasslefreeclipart.com/clipart_school/boy_confused.html



ActionScript Notes
--Link to URLs
AS2
monkey_btn.onRelease = function() {
    getURL(“http://www.flashthusiast.com”);
};

AS3
monkey_btn.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
function mouseDownHandler(event:MouseEvent):void {
    navigateToURL(new URLRequest(“http://www.flashthusiast.com/));
}

--Link to Scenes/Frames
AS2
mbutton1.onRelease = function() {
	gotoAndStop(2, “monkeyScene”);
};

AS3
stop();
 
mbutton1.addEventListener(MouseEvent.MOUSE_DOWN, mouseHandler1);
 
function mouseHandler1(event:MouseEvent):void {
 
gotoAndStop(2, “monkeyScene”);
 
}

--Sound (play throughout, start automatically)
AS3
var music:Sound = new Sound(new URLRequest(“song.mp3”));
music.play();
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